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Defining a List 

 Each column is a field with a particular item of information in the list. 

 Each row is a record (the information on a person, etc.). 

 The top row contains labels identifying each field. 

 Do not use blank rows or columns to separate one part of the list from another. 

 The list is separated from the other information on the spreadsheet by blank rows and/or columns OR the 

additional information is placed on a separate sheet. 

Using a Form to Enter, Change, or Delete Information 

Making the Form Available 

 Click on the Microsoft Office Button. 

 Click on the Excel Options button. 

 Click on Customize in the left pane. 

 Click on the Choose commands from down arrow and choose All commands. 

 Scroll through the list and click on Form…. 

 Click on the Add button. 

 Click on OK. 

Opening the Form 

 Click in the list. 

 On the Quick Access toolbar, click on the Form... button. 

Using the Form 

 To add a new record, click on the New button. 

 To find the next record, click on the Find Next button. 

 To find the previous record, click on the Find Prev button. 

 To get rid of a record, find the record and then click on the Delete button. 

 To find a record with certain information, click on the Criteria button. 

 Click in the appropriate field and enter the information being sought. 

 Click on the Find Next button. 

Sorting Lists 

Simple Sorting 

 Click in the column to be sorted.  

 On the Ribbon, click on the Home tab. 

 In the Editing group, click on the Sort & Filter button and choose Sort A to Z or Sort Z to A. 
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Custom Sorting 

 Click in the list. 

 On the Ribbon, click on the Home tab. 

 In the Editing group, click on the Sort & Filter button and choose Custom Sort…. 

 Click on the down arrow of the Sort By box and choose the field to sort by. 

 Click on the down arrow of the Sort On box and choose Values. (Other choices include Cell Color, Font 

Color, or Cell Icon.) 

 Click on the down arrow of the Order box and choose A 

to Z or Z to A. 

 Click on the Add Level button to add the next field to be 

used in the sort. 

 Choose the desired field to sort by, values to sort on, and 

the desired order of the sort.  

 Add or delete levels to the sort as needed. 

 If the list does not have a header row with names for the fields, be sure to remove the checkmark from My 

data has headers at the top of the window. 

 Click on OK. 

Sorting Left to Right instead of Top Down 

 Click in the list. 

 On the Ribbon, click on the Home tab. 

 In the Editing group, click on the Sort & Filter button and choose Custom Sort…. 

 Click on the Options… button. 

 Click on the Sort left to right radio button and then click OK. 

 Set up the sort as mentioned above. 

 Click on OK. 

Sorting by Date 

 Click in the list. 

 On the Ribbon, click on the Home tab. 

 In the Editing group, click on the Sort & Filter button and choose Custom Sort…. 

 Set up the sort the usual way. 

 Click on the Options button. 

 Click on the down arrow under First key sort order and choose one with the months listed. 

 Click on OK and then click on OK again. 

Sorting by the Day of the Week or by the Month of the Year 

 Click in the list. 

 On the Ribbon, click on the Home tab. 

 In the Editing group, click on the Sort & Filter button and choose 

Custom Sort…. 

 Click on the Options button. 

 Click on the down arrow under First key sort order and choose one 

with the week days listed. 

 Click on OK and then click on OK again. 
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Filter 

 Click in the list. 

 On the Ribbon, click on the Home tab. 

 In the Editing group, click on the Sort & Filter button and choose Filter. 

 Click on the down arrow of the column to be filtered. 

 Choose from the list the items to be displayed. 

 Click on OK. 

Changing the Filter 

 Click on the filter button at the top of the column. 

 Choose from the list the items to be displayed. 

 Click on OK. 

Clearing a Filter 

 Click on the filter button at the top of the column. 

 Click on Clear Filter From “------“. 

Showing Items with Blank Cells 

 Click in the column to be filtered. 

 Click on the button at the top of the column. 

 Click to remove the checkmark from Select All. 

 Scroll to the bottom of the list and choose Blanks. 

 Click on OK. 

Showing All of the Information 

 Click on the filter button at the top of the column. 

 Click in the Select All box. 

 Click on OK. 

Turning Off the Filter 

 On the Ribbon, click on the Home tab. 

 In the Editing group, click on the Sort & Filter button and choose Filter. 

 When the filter is turned off, all data is displayed. 
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Advanced Filtering 

 Advanced filtering will allow filtering on more than one column at a time or more than one condition in a 

single column. 

Multiple Columns 

 On the Ribbon, click on the Home tab. 

 In the Editing group, click on the Sort & Filter button and choose Filter. 

 Click on the down arrow of the first column to be filtered. 

 Choose from the list the items to be displayed. 

 Click on OK. 

 Click on the down arrow of the next column to be filtered. 

 Choose from the list the items to be displayed. 

 Click on OK. 

 The items that have both conditions chosen are displayed. 

Text Filters 

 A detailed filter can be applied based on the text in the cells. 

 On the Ribbon, click on the Home tab. 

 In the Editing group, click on the Sort & Filter button and choose Filter. 

 Click on the down arrow of the column to be filtered. 

 Click on Text Filters and then choose the desired filter. 

 Choices include: Equals…, Does Not Equal…, Begins With…, 

Ends With…, Contains…, Does Not Contain…, or Custom 

Filter…. 

 Enter the desired text in the second box. 

 Note – A second condition can be applied by clicking on the down 

arrow of the box on the second row and selecting the desired choice. 

 Choosing And includes cells in which both conditions are true.  

 Choosing Or includes cells in which either condition is true. 

 Click on OK. 

Number Filters 

 A detailed filter can be applied based on the numbers in the cells. 

 On the Ribbon, click on the Home tab. 

 In the Editing group, click on the Sort & Filter button and choose Filter. 

 Click on the down arrow of the column to be filtered. 

 Click on Text Filters and then choose the desired filter. 

 Choices include: Equals…, Does Not Equal…, Greater Than…, 

Greater Than or Equal To…, Less Than…, Less Than or Equal 

To…, Between…, Top 10…, Above Average…, Below 

Average…, or Custom Filter…. 

 Enter the desired number(s) in the second box. 

 Note – A second condition can be applied by clicking on the down 

arrow of the box on the second row and selecting the desired choice. 

 Choosing And includes cells in which both conditions are true.  

 Choosing Or includes cells in which either condition is true. 

 Click on OK. 
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Filtering with Wildcards 

 Wildcards are used when an exact match may not give the desired information. 

 Single Character 

 Use a ? to indicate a single character.  i.e. Anderson or Andersen, type Anders?n. 

 Multiple Characters 

 Use a * to indicate multiple characters.  i.e. Anderson, Andersen, Anders, etc.  Type Ander*. 

 The more characters included in front of the asterisk, the more specific it will be. 

Special Functions (Formulas) for Lists 

 Click in the cell the function is to be placed in. 

 On the Ribbon, click on the Formulas tab. 

 In the Function Library group, click on the Insert Function button. 

 Find the desired function in the list of the Insert Function window. 

 Click on OK. 

 Choose or enter the necessary information for the function. 

 OR click on the Insert function button on the Input Line. 

Finding a Formula  

 Click in the cell where the formula should go. 

 On the Ribbon, click on the Formulas tab. 

 In the Function Library group, click on the Insert Function button. 

 In the Search for a function box, enter a description of what the 

function should do. 

 Click on the Go button. 

 Some choices appear in the Select a function box.  

 Click on one of the functions to see a description in the space below 

the box. 

 Click on the desired function in the Select a function box. 

 Click on OK. 

COUNTIF 

 This function allows you to count how many items in a list meet the criteria. 

 =COUNTIF(range,criteria) 

 For example, the function =COUNTIF(E2:E24,”F”) might be used in an employee list to count how many 

of the employees listed in rows 2 -24 were female (assuming column F indicated sex of employee). 

 Another example, the function =COUNTIF(G2:G24,”>=35") might be used in a list of buildings to count 

how many of them were 35 years old or older (assuming column G indicated the age of the building). 

SUMIF 

 This function is used in the same way COUNTIF is used. 

 =SUMIF(range,criteria,sum_range) 

 For example, the function =SUMIF(G2:G24,”>=35",H2:H24) might be used in a list of buildings to total 

the cost of proposed renovations for buildings older 35 years old or older (assuming column G indicates the 

age of the building and column H indicates the cost of the renovation). 

D Functions 

 D functions are special functions that work with databases. 
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DAVERAGE 

 This function is used to find the average of a range of data that meets a specified criteria. 

 =DAVERAGE(range,field_averaged,criteria_range) 

 For example, the function =DAVERAGE(A7:G26,”Salary”,A1:A2) might be used in a list of employees to 

find the average salary of those who met the criteria.  If cell A1 is “Age” and cell A2 is “>=40", the 

function would calculate the average salary for those 40 and older. 

Pivot Tables 

What is a Pivot Table? 

 A Pivot Table is a table that summarizes a list of information. 

 Pivot Tables are dynamically linked to the original data and change as the data in the original changes. 

 Pivot Tables can be adjusted after they are created to perform different mathematical operations. 

Starting the Pivot Table 

 Click in the middle of the list, being sure not to select multiple cells. 

 On the Ribbon, click on the Insert tab.  

 In the Tables group, click on the PivotTable button. 

 Notice the area highlighted by the dotted area. 

 Check to see if the correct data has been selected. 

 If the selected data is not correct: 

o Click on the button at the end of the Table/Range box. 

o Select the desired data 

o Click press the Enter key. 

 To create the PivotTable in a new worksheet, click to choose New 

Worksheet. 

 To create the PivotTable in an existing worksheet, click to choose 

Existing Worksheet and then choose a location in the Location 

box. 

 Click on OK. 
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Structure of a PivotTable 

 There are four areas in a PivotTable. 

o Column Labels – Column labels are at the top right of the 

PivotTable and provide subdivisions such as the year or date of the 

item. 

o Row Labels – Row labels are at the left side of the PivotTable and 

provide names for the records displayed. 

o Values – Values are at the bottom right of the PivotTable and can be 

summed, averaged, etc. 

o Report Filter – 

Allows for the data to 

be restricted by 

choosing specific 

data. 

 Fields are the bits of 

information that are usually 

arranged in a column on the 

list or database. 

 Fields can be placed either as row fields or column fields. 

 Data items are fields which may be totaled, averaged, counted, etc.  Items being counted may be text items, 

but if a sum, an average, a standard deviation, etc., is desired, the fields must be numeric. 

Pivot Table Options 

 On the Ribbon, click on the Options tab of PivotTable Tools. 

 In the PivotTable group, click in the PivotTable Name box and enter a name for the 

PivotTable. 

 In the PivotTable group, click on the Options button. 

 Click on the Layout & Format tab and make desired choice about the layout of the 

PivotTable and the format of the cells. 

 Click on each of the other tabs and make choices as desired. 

 Click on OK. 

Arranging the Pivot Table with the Field List 

 To display the Pivot Table Field List, 

o On the Ribbon, click on the Options tab of PivotTable 

Tools. 

o In the Show/Hide group, click on the Field List button. 

 To arrange the PivotTable Field List pane, click on the view button in 

the top right corner and choose Field Section and Area Section Stacked. 

 Click in the Field Section to select a field to be included in the PivotTable, 

 OR click on the desired field in the Field Section and drag it to the desired area 

of the PivotTable. 

 To change the location of the field, in the Area Section, click on the field 

button and drag it to the desired area.  

  



 Page 9 

Paul Waite 

Educational Technology Center  Revised  11/13/2007 

Davis School District, Farmington, UT 84041 

Changing the Calculation 

 Click in the PivotTable in a cell of the area to be changed. 

 On the Ribbon, click on the Options tab of PivotTable Tools. 

 In the Active Field group, click in the Field Settings 

button. 

 Click on the Summarize by tab. 

 Choose the desired calculation. 

 In the Custom Name box, enter a name for the calculation. This name appears 

in the PivotTable at the top of the Row Labels. 

 Click on OK. 

 Note – Additional options in the presentation of the data are available by 

clicking on the Show values as tab in the Value Field Settings window. These 

options include the ability to show the values as a difference, a percentage, or a 

running total. 

Changing the Number Format 

 Highlight the cells in the PivotTable to be changed. 

 On the Ribbon, click on the Home tab. 

 Use the buttons in the Number group to format the numbers as desired. 

Refreshing Data 

 When changes are made to the original data, the PivotTable should be refreshed. 

 On the Ribbon, click on the Options tab of PivotTable Tools. 

 In the Data group, click on the Refresh button. 

Sorting the List 

 Click in the column of the PivotTable the list is to be sorted by. 

 On the Ribbon, click on the Options tab of PivotTable Tools. 

 In the Sort group, click on the AZ button to sort from A to Z OR 

click on the ZA button to sort from Z to A. 

 To sort with more options, in the Sort group, click on the Sort 

button. 

o To sort by clicking and dragging the items to the desired location, 

choose Manual. 

o To sort A to Z on a different field, choose Ascending (A to Z) by, 

then click on the down arrow and choose the desired item. 

o To sort Z to A on a different field, choose Descending (Z to A) by, 

then click on the down arrow and choose the desired item. 

o Click on OK. 

Filtering the List 

 A filter can be used to select which items are to be displayed in the list. 

 To filter Row Labels, in the PivotTable, click on the filter button at the top of the Row Fields area of the 

PivotTable. 

 Filter the list as desired. Detailed instructions on Filtering are found on pages 4 and 5. 

  



 Page 10 

Paul Waite 

Educational Technology Center  Revised 11/13/2007 

Davis School District, Farmington, UT 84041 

PivotTable Layout 

 On the Ribbon, click on the Design tab of PivotTable Tools. 

 In the Layout group are various options for the layout of the PivotTable. 

 To add subtotals to the PivotTable, click on the Subtotals button. 

 To add totals to the PivotTable, click on the Grand Totals button. 

 Click on the Report Layout button and choose Show in Compact Form, 

Show in Outline Form, or Show in Tabular Form. 

PivotTable Styles 

 On the Ribbon, click on the Design tab of PivotTable Tools. 

 In the PivotTable Styles group click on the desired style. 

 Make adjustments to the style with choices in the PivotTable Style Options group. 

 


